思科、华为、H3C命令对照表

发布时间:2018年09月05日 阅读:399 次

思科

华为

H3C

描述

no

undo

undo

取消/关闭 当前设置

show

display

display

查看、显示

exit

quit

quit

退回上级

hostname

sysname

sysname

设置主机名

en, config terminal

system-view

system-view

进入全局模式

delete

delete

delete

删除文件

reload

reboot

reboot

重启

write

save

save

保存当前配置

username

local-user

local-user

创建用户

shutdown

shutdown

shutdown

禁止、关闭

show version

display version

display version

显示当前系统版本

show startup-config

display saved-configuration

display saved-configuration

查看已保存过的配置

show running-config

display current-configuration

display current-configuration

显示当前配置

no debug all

ctrl+d

ctrl+d

取消所有debug命令

erase startup-config

reset saved-configuration

reset saved-configuration

删除配置

end

return

return

退到用户视图

exit

logout

logout

登出

logging

info-center

info-center

指定信息中心配置信息

line

user-interface

user-interface

进入线路配置(用户接口)模式

start-config

saved-configuration

saved-configuration

启动配置

running-config

current-configuration

current-configuration

当前配置

host

ip host

ip host

host名字和ip地址对应

交换部份:




enable password

set authentication password simple

set authentication password simple

配置明文密码

interface type/number       

port type/number       

port type/number       

进入接口

interface vlan 1               

interface vlan 1              

interface vlan 1               

进入vlan配置vlan管理地址

interface rang

interface ethID to ID

interface ethID to ID

定议多个端口的组

enabl esecret

super password

super password

设置特权口令

duplex (half|full|auto)

duplex (half|full|auto)

duplex (half|full|auto)

配置接口状态

speed (10/100/1000)

speed (10/100/1000)

speed (10/100/1000)

配置端口速率

switchport mode trunk

port link-type trunk

port link-type trunk

配置trunk

vlan ID  /no vlan ID

vlan ID  /undo vlan ID

vlan ID  /undo vlan ID

添加、删除vlan

switchport access vlan ID

port vlan ID

port vlan ID

将端口接入vlan

show interface

display interface

display interface

查看接口

show vlan ID

display vlan ID

display vlan ID

查看vlan

encapsulation

link-protocol

link-protocol

封装协议

channel-group 1 mode on

port link-aggregation group 1

port link-aggregation group 1

链路聚合

ip routing

默认开启

默认开启

开启三层交换的路由功能

no switchport

不支持

不支持

开启接口三层功能

vtp domain

GVRP

GVRP

对跨以太网交换机的VLAN进行动态注册和删除

spanning-tree vlan ID root primary



stp配置根网桥

spanning-tree vlan ID priority



配置网桥优先级

show spanning-tree



查看STP配置





路由部份:




ip route 0.0.0.0 0.0.0.0

ip route-static 0.0.0.0 0.0.0.0

ip route-static 0.0.0.0 0.0.0.0

配置默认路由

ip route 目标网段+掩码 下一跳

ip route-static 目标网段+掩码 下一跳

ip route-static 目标网段+掩码 下一跳

配置静态路由

show ip route

display ip routing-table

display ip routing-table

查看路由表

router rip /network 网段

rip /network 网段

rip /network 网段

启用rip、并宣告网段

router ospf

ospf enable

ospf enable

启用ospf

network ip 反码 area <area-id>

ospf enable area <area-id>

ospf enable area <area-id>

配置OSPF区域

no auto-summary

rip split-horizon

rip split-horizon

配置RIP V2水平分割

show ip protocol

display ip protocol

display ip protocol

查看路由协议

access-list 1-99 permit/deny IP

rule normal permit source IP

rule normal permit source IP

标准访问控制列表

access-list 100-199 permit/deny protocol source IP+反码destination IP+反码 operator operan

rule {normal|special}{permit|deny}{tcp|udp}source {<ip wild>|any}destination <ip wild>|any}[operate]

rule {normal|special}{permit|deny}{tcp|udp}source {<ip wild>|any}destination <ip wild>|any}[operate]

扩展访问控制列表

standby group-number ip virtual-ip

vrrp vrid number virtual-ip

vrrp vrid number virtual-ip

配置HSRP组

standby group-number priority

vrrp vrid number priority

vrrp vrid number priority 

配置HSRP优先级

standby group-number preempt

vrrp vrid number preempt-mode

vrrp vrid number preempt-mode

配置HSRP占先权

standby group-number track

配置端口跟踪

ip nat inside source static

nat server global <ip> [port] inside <ip> port [protocol]

nat server global <ip> [port] inside <ip> port [protocol]

配置静态地址转换


Tag:思科 华为 H3C
相关文章